www.1862.net > mysql驱动包与mysql版本

mysql驱动包与mysql版本

云盘链接已私信发送给你了,你看一下是不是你需要的如果还有哪位朋友想要,请点“赞”此条回答以后,在下面的评论里留下您的联系方式学无止境,希望回答能给你带来帮助,如果满意请采纳,不满意的话请继续追问.

是的,如果用JDBC操作数据库,必须导入JDBC驱动,否则编译出错!

这跟Mysql的版本和JDK的版本升级是有关系的,Mysql从3.x 4.x 到5.x都不同版本的mysql-connector/J,在Mysql官网可以看到每个版本的mysql-connector/J的ChangeLog,现有的版本号是:5.1.x、5.0.x、3.1.x、3.0.x、2.0.x和1.2.x,每一个版本的

jdbc和连接池对于你这个场景来说,都足够,既然用spring管理了,建议还是使用连接池,另外,spring自身没有实现连接池,一般都是对第三方连接池的包装,常见的有C3P0,dbcp以及最近比较流行的boneCP等,这几个配置都差不多太多,以boneCP为例:

再附上6.0的链接,发现能支持mysql5.5的就5.1和6.0的驱动了

当然最好是mysql版本对应相应的驱动,但高版本的驱动一般都能兼容低版本的.首先得保证有驱动,数据库连接权限,驱动要放进自己的程序里,一般没什么问题,给你一个程序,也是刚才别人问我的,他的程序没有问题.import java.sql.*;

1.用tomact去配置数据库连接池,具体操作在:http://wenku.baidu.com/view/7006bdc408a1284ac85043d1.html2.去百度文库里查DBhelper类,很多人上传了 稍微改下就行

安装包是mysql的核心,简单点说就是存放和管理你的数据的地方.驱动是起着连接java和mysql的桥梁,你想用java存取数据都要通过这个桥梁.sql文件是一些sql语句,用来创建数据库或增删数据用的,应该不用加到java项目去吧.如果你想执行这个sql文件,就打开mysql的命令提示窗口,输入\. 文件的路径

不是,可以对应5.0以上的都可以的

呵呵.不一定要相同,不过最好jdbc驱动的版本等于或者高于mysql的版本

网站地图

All rights reserved Powered by www.1862.net

copyright ©right 2010-2021。
www.1862.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com