www.1862.net > jDk1.8用哪个版本tomCAt

jDk1.8用哪个版本tomCAt

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的socket,也就是说tomcat是在jdk环境下运行的.而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.72,具体记不清楚了)之前还是用jdk1.6写的,7.0.72之后是jdk1.7写的.那么jdk1.8肯定是支持tomcat7的

tomcat9支持:jdk8(含)以下版本;tomcat8支持:jdk7(含)以下版本;tomcat7支持:jdk6(含)以下版本;你根据自己的环境来选择.

tomcat6.0到tomcat8.0d任何一个版本都行

你弄反了, 是eclipse的运行需要jdk来支持,提供jvm虚拟机环境, 也就是要先安装jdk,并且配置环境变量,然后再使用eclipse.eclipse目前最新版是4.6(neno版本) 必须要最新的jdk1.8支持以前的老版本eclipse 都可以用jdk1.7

1、修改tomcat/bin/catalina.bat,增加 setJAVA_HOME=XXXXXX,其中XXXXXX为jdk的路径,如c:/j2sdk1_42、修改tomcat/bin/setclasspath.bat,同样增加 setJAVA_HOME=XXXXXX其实这个问题是很初级的,但是一般人常常忘了步骤2,导致的结果就是特定版.

一一对应的就好,比如tomcat7 和jdk7.jdk可以向下兼容tomcat,tomcat5 6 7 也可以用jdk7

jdk至少要1.5以上的吧 tomcat现在用的比较多的应该是6.0 jdk比较关键 版本高了功能也有所增加的

实际工作的话是以稳定为主,java使用1.6最好,开发时应选用与实际工作相同的jdktomcat是开发用server,实际工作的话会选用websphere、weblogic、jboss等,所以开发时tomcat选什么版本都无所谓

首先环境变量path的jdk路径要设置到1.7版本的然后改注册表hkey_local_machine/software/javasoft/java runtime environment将currentversion 从1.8改为1.7若你安装的新版本是1.8,path路径,注册表都改为对应的1.8版本

哪个都行 jdk是向下兼容的 你只要环境变量配对了 tomcat都能跑

网站地图

All rights reserved Powered by www.1862.net

copyright ©right 2010-2021。
www.1862.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com