www.1862.net > jDk和tomCAt对应版本

jDk和tomCAt对应版本

有关系的.比如tomcat7,对应的jdk就是1.7.tomcat8,对应的就是jdk1.8 依次类推

tomcat 官网很清楚http://tomcat.apache.org/whichversion.htmljdk1.6.0_23 支持 Servlet/JSP Spec 2.5/2.1但不支持 3.0/2.2,所以 只能使用 Apache Tomcat version 6.0.x 或者 7.0.x也就是说 tomcat 6 以上版本都可以(7 兼容)

实际工作的话是以稳定为主,java使用1.6最好,开发时应选用与实际工作相同的jdktomcat是开发用server,实际工作的话会选用websphere、weblogic、jboss等,所以开发时tomcat选什么版本都无所谓

这三个软件是不需要对应的版本的,只是看他们是否支持一些特定功能.推荐的版本如下:jdk:最新版是java8, 可以java6以上的版本,包括java6.tomcat:一般推荐tomcat5以上,有tomcat5/6/7/8几个版本,有些老一点版本的myeclipse可能还没支持到tomcat8 ,所以推荐用5,6 ,7三个版本.myeclipse:myeclipse6以上都行,不过不要用myeclipse2015,因为是最新版还不能完美破解,就算破解了也会出问题,所以选其他版本,推荐myeclipse2014版.

一一对应的就好,比如tomcat7 和jdk7.jdk可以向下兼容tomcat,tomcat5 6 7 也可以用jdk7

这个和java版本没有关系,只和你想用的JSP/Servlet版本有关系Servlet/JSP tomcat2.5/2.1 6.0.x 2.4/2.0 5.5.x 2.3/1.2 4.1.x 2.2/1.1 3.3.x

尽量用新的版本,很多旧版本中的类库已被废除,所以新版本的可能就不认识那些类

5.5和6.0都可以

JDK 1.6 tomcat 6.0

我这里6和7都有,不过我用的是6.Tomcat本身是块Servlet容器的试验田.所以它的版本是跟Servlet和JSP的规范一起发展的.几个早起的版本我就不说了,我说下Tomcat5和6吧.Tomcat5.x是基于3和4的.遵循新的Servlet2.4,JSP2.0规范.它的

网站地图

All rights reserved Powered by www.1862.net

copyright ©right 2010-2021。
www.1862.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com